Ticket Submission Outage

Incident Report for Foodsby

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 15:53 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 21, 2025 - 11:23 CDT

Investigating

We are currently experiencing an issue with submitting tickets from the order details page. Please submit support and cancellation requests through support@foodsby.com.
Posted Mar 21, 2025 - 10:58 CDT
This incident affected: Individual Ordering.